1006 Sign In and Sign Out (25 )

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer , which is the total number of records, followed by  lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目解读:一些人进行签到签退,第一个来的会开门,最后一个走的会关门,给出一串ID及他们的签到签退时间,找到是谁开门和关门。

解题思路:按照签到和签退的时间排序,注意字符串可以直接进行排序。

AC代码

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
struct student{
    string ID;
    string intime;
    string outtime;
    student(string a1, string a2, string a3){
        ID = a1;
        intime = a2;
        outtime = a3;
    }
};
bool cmp1(student a, student b){
    return a.intime < b.intime;
}
bool cmp2(student a, student b){
    return a.outtime > b.outtime;
}

int main(int argc, const char * argv[]) {
    int n;
    vector<student> stu;
    cin >> n;
    for( int i = 0 ; i < n ; i ++ ){
        string a1,a2,a3;
        cin >> a1 >> a2 >> a3;
        stu.push_back(student(a1,a2,a3));
    }
    sort(stu.begin(),stu.end(),cmp1);
    cout << stu[0].ID << " ";
    sort(stu.begin(),stu.end(),cmp2);
    cout << stu[0].ID;

    return 0;
}

 


0 条评论

发表评论

Avatar placeholder